You do require the Flash Player 8 or higher.